Plans to go open source

short notes for those not reading all the forums
alienpolygon
Newbie
Posts: 2
Joined: Tue Feb 19, 2019 12:06 am

Re: Plans to go open source

Postby alienpolygon » Thu Apr 09, 2020 7:10 am

Hello All!

This is something that interests me greatly just so that if I ever needed to host myself I could.
Could the first post be updated with all of the documentation and links to the source? I would like to make sure I have everything, and I'm sure others would appreciate it.

Thanks a ton for this, seriously!

User avatar
Cole
Newbie
Posts: 8
Joined: Mon Oct 03, 2016 11:29 am

Re: Plans to go open source

Postby Cole » Fri Apr 10, 2020 2:30 pm

WOW that's great! you're the best guys!

User avatar
Neoplasmic
Sr. Member
Posts: 254
Joined: Wed Mar 25, 2015 5:00 pm

Re: Plans to go open source

Postby Neoplasmic » Thu Apr 16, 2020 9:43 pm

So everyone will be able to host in their own servers? sorey i have trouble understanding to know what's "Open source".

User avatar
Tegato
Newbie
Posts: 44
Joined: Wed Jun 01, 2016 3:00 am
Location: Console Master Race

Re: Plans to go open source

Postby Tegato » Thu Apr 16, 2020 9:59 pm

So everyone will be able to host in their own servers? sorey i have trouble understanding to know what's "Open source".
I'm also curious about this. Also, has anyone played around with it and found anything interesting?
Console Player:
HN: Blubs
Childhood Playstation 2 (SCPH-50000) and Sony HDD (40G) with OPL
PlayStation 3 4X (2 CECHA01 60G Launch, CECHB01 1 TB, CECHE01 1 TB)

User avatar
hill73n
Full Member
Posts: 163
Joined: Mon May 20, 2019 4:49 am
Location: Australia

Re: Plans to go open source

Postby hill73n » Thu Apr 16, 2020 10:26 pm

So everyone will be able to host in their own servers? sorey i have trouble understanding to know what's "Open source".
Correct.

User avatar
hill73n
Full Member
Posts: 163
Joined: Mon May 20, 2019 4:49 am
Location: Australia

Re: Plans to go open source

Postby hill73n » Thu Apr 16, 2020 10:52 pm

So everyone will be able to host in their own servers? sorey i have trouble understanding to know what's "Open source".
I'm also curious about this. Also, has anyone played around with it and found anything interesting?
refan988 and leotreves have both already done this. refan988 posted earlier in this thread a link to download his server image that anyone can use after changing a couple of things like IP address. Read the thread or ask one of the guys commenting there if you need help...

Here is the post: viewtopic.php?f=10&t=5251&start=45

Here is the GoogleDrive download link:https://drive.google.com/open?id=1Tda15 ... yKYt-T3K94

User avatar
Neoplasmic
Sr. Member
Posts: 254
Joined: Wed Mar 25, 2015 5:00 pm

Re: Plans to go open source

Postby Neoplasmic » Fri Apr 17, 2020 9:27 am

So everyone will be able to host in their own servers? sorey i have trouble understanding to know what's "Open source".
Correct.
I see thanks.

refan988
Full Member
Posts: 139
Joined: Wed Jul 10, 2013 6:45 pm

Re: Plans to go open source

Postby refan988 » Fri Apr 17, 2020 5:53 pm

The server is in an ova file that you can import into Oracle VM Virtualbox. I also extracted the server to a disk image file if anyone wanted to run it on a physical machine using HDD Raw Copy to copy the image onto a hard drive. Link is here.

User avatar
ALED
Newbie
Posts: 4
Joined: Sat Feb 13, 2016 2:16 pm

Re: Plans to go open source

Postby ALED » Sun Apr 19, 2020 2:15 pm

@refan988

Does DNAS need to be configured on your virtual machine, other than the normal run sequence?
I'm getting to 50% DNAS Auth and immediately failing out with a -611 error.
(Notably, this is different than using an incorrect IP where I get stuck in a 0-40% loop).

My PCSX2 environment can properly connect to the normal obsrv, so I don't believe that's the issue.
The VM itself is able to connect to the internet, so I believe its networking is correct.
I've also forwarded my ports and set my ip to static, on the off chance either were causing the problem.

[Edit 1] - After some further poking around (I ran through the setup document on the_fog's repo), I found that I wasn't getting a response when testing the DNAS server. After partially running the install from the top (not sure if I actually did much-- I tried not to overwrite anything that already existed), I changed the ip to localhost and tested again. I was able to get a response from this, so I'm assuming it's just an issue configuring the server's IP between the virtual machine and my computer.

[Edit 2] - I ended up just running through the setup document on my own pi. I had intended to copy your HDD file onto my SD card, but it's 80GB and my card is 32GB. Maybe it could be smaller? Things are looking more promising, as I can actually see the apache server running on my pi from my laptop. I'm stuck on the setup now; the install command for php7.0-fpm throws me an unable to locate. It seems to work on your image-- How did you get around this? [Edit 2.5 - May be due to debian vs raspbian]

[Edit 3] - I attempted to install PHP 7.1, 7.2, 7.3, and PHP 5, but they all give me the following when I try to test the dnas server via wget:

Code: Select all

> wget --no-check-certificate -O - https://gate1.jp.dnas.playstation.org/gai-gw/v2.5_i-connect --2020-04-19 21:39:05-- https://gate1.jp.dnas.playstation.org/gai-gw/v2.5_i-connect Resolving gate1.jp.dnas.playstation.org (gate1.jp.snas.playstation.org)... 192.168.0.136 Connecting to gate1.jp.dnas.playstation.org (gate1.jp.dnas.playstation.org)|192.168.0.136|:443... connected. GnuTLS: A TLS fatal alert has been received. GnuTLS: received alert [40]: Handshake failed Unable to establish SSL connection.

I've re-installed the DNAS portion and verified that everything's written correctly in apache's httpd.conf.
If anyone has any recommendations, I'd appreciate the assistance. I'll probably go back to working with the VM tomorrow.

[Edit 4] - I was able to get the DNAS working via PHP 7.1, I forgot to turn on SSH for my pi :V
Last edited by ALED on Wed Apr 22, 2020 12:22 pm, edited 1 time in total.

User avatar
hobbes_182
Full Member
Posts: 239
Joined: Thu Jan 23, 2014 12:08 am
Location: _mobius

Re: Plans to go open source

Postby hobbes_182 » Wed Apr 22, 2020 6:39 am

Hey dudes I also have a question re: running the server on a Pi.

Is there an actual user limit where the server could see performance issues? For example, the max users I have seen online on obsrv have been around 76. Has anyone seen a number higher than that? Or is the Pi a safe bet to release on?

I am also working on getting this running, would love to have all of my bases covered. :ugeek:
Image
Image

refan988
Full Member
Posts: 139
Joined: Wed Jul 10, 2013 6:45 pm

Re: Plans to go open source

Postby refan988 » Sat Apr 25, 2020 2:47 am

@refan988

Does DNAS need to be configured on your virtual machine, other than the normal run sequence?
I'm getting to 50% DNAS Auth and immediately failing out with a -611 error.
(Notably, this is different than using an incorrect IP where I get stuck in a 0-40% loop).

My PCSX2 environment can properly connect to the normal obsrv, so I don't believe that's the issue.
The VM itself is able to connect to the internet, so I believe its networking is correct.
I've also forwarded my ports and set my ip to static, on the off chance either were causing the problem.

[Edit 1] - After some further poking around (I ran through the setup document on the_fog's repo), I found that I wasn't getting a response when testing the DNAS server. After partially running the install from the top (not sure if I actually did much-- I tried not to overwrite anything that already existed), I changed the ip to localhost and tested again. I was able to get a response from this, so I'm assuming it's just an issue configuring the server's IP between the virtual machine and my computer.

[Edit 2] - I ended up just running through the setup document on my own pi. I had intended to copy your HDD file onto my SD card, but it's 80GB and my card is 32GB. Maybe it could be smaller? Things are looking more promising, as I can actually see the apache server running on my pi from my laptop. I'm stuck on the setup now; the install command for php7.0-fpm throws me an unable to locate. It seems to work on your image-- How did you get around this? [Edit 2.5 - May be due to debian vs raspbian]

[Edit 3] - I attempted to install PHP 7.1, 7.2, 7.3, and PHP 5, but they all give me the following when I try to test the dnas server via wget:

Code: Select all

> wget --no-check-certificate -O - https://gate1.jp.dnas.playstation.org/gai-gw/v2.5_i-connect --2020-04-19 21:39:05-- https://gate1.jp.dnas.playstation.org/gai-gw/v2.5_i-connect Resolving gate1.jp.dnas.playstation.org (gate1.jp.snas.playstation.org)... 192.168.0.136 Connecting to gate1.jp.dnas.playstation.org (gate1.jp.dnas.playstation.org)|192.168.0.136|:443... connected. GnuTLS: A TLS fatal alert has been received. GnuTLS: received alert [40]: Handshake failed Unable to establish SSL connection.

I've re-installed the DNAS portion and verified that everything's written correctly in apache's httpd.conf.
If anyone has any recommendations, I'd appreciate the assistance. I'll probably go back to working with the VM tomorrow.

[Edit 4] - I was able to get the DNAS working via PHP 7.1, I forgot to turn on SSH for my pi :V
Even though my disk image says it's for an 80gb drive, I shrunk it down to around 8-10gb so as long as hddrawcopy goes to copy at least 10gb, it should run. As for the issue with php 7.1, I solved it by installing php 5.6. I found that I wasn't able to load the server after getting past dnas and discovered that the issue was the php version 7 not being compatible in the log files. I ran the following commands in the terminal to install php5.6:

sudo apt update

sudo apt upgrade

sudo apt install ca-certificates apt-transport-https

wget -q https://packages.sury.org/php/apt.gpg -O- | sudo apt-key add -

echo "deb https://packages.sury.org/php/ stretch main" | sudo tee /etc/apt/sources.list.d/php.list

sudo apt update
sudo apt install php5.6

sudo apt install php5.6-cli php5.6-common php5.6-curl php5.6-mbstring php5.6-mysqlnd php5.6-xml
sudo apt install php5.6-fpm

javac -d bin -cp lib/mysql-connector-java-5.1.48-bin.jar bioserver/*.java
java -cp lib/mysql-connector-java-5.1.48-bin.jar:bin bioserver.ServerMain

User avatar
the_fog
Sr. Member
Posts: 2541
Joined: Sun May 26, 2013 1:47 pm
Location: The Hive
Contact:

Re: Plans to go open source

Postby the_fog » Sat May 09, 2020 5:49 am

Ouch, you shouldn’t run php5.6 anymore. Seriously 😒
A php7 compatible version of DNASrep is available at https://gitlab.com/gh0stl1ne/DNASrep

User avatar
hobbes_182
Full Member
Posts: 239
Joined: Thu Jan 23, 2014 12:08 am
Location: _mobius

Re: Plans to go open source

Postby hobbes_182 » Sun May 24, 2020 6:31 am

Hey guys!

I dusted off an old Acer Aspire Revo 1600 and installed Debian 10 to see if I could get the server running. So far so good, but I did hit a snag with INSTALLING AND SETTING UP DNAS

The PDF reads:

DNAS emulation is currently done by a few PHP scripts. The lite version of Raspbian stretch doesn’t
have it preinstalled. Let’s adjust the installation:

➢ sudo apt-get install php7.0-fpm

Last but definitely not least we’ll setup Apache to run a SSL enabled PHP7 webserver with DNAS
certificates.

However, when I run that I get the following error:

Code: Select all

Reading package lists… Done Building dependency tree Reading state information… Done E: Unable to locate package php7.0-fpm E: Couldn’t find any package by glob ‘php7.0-fpm’ E: Couldn’t find any package by regex 'php7.0-fpm’

I did check https://packages.debian.org/stretch/php7.0-fpm, I did not see my architecture listed [attached].

After running

Code: Select all

uname -m


I got

Code: Select all

i686

I was wondering if you guys could point me in the right direction. Is PHP 7.0-fpm not available for my architecture?

Would I have better luck running a Virtual Machine on my 64bit main system? I am also thinking of purchasing a Pi 4, I'm wondering if that would be the best way to go in order to have dedicated hardware for the Server.
Attachments
Capture.PNG
Capture.PNG (13.49 KiB) Viewed 3403 times
Image
Image

User avatar
Isles487
Sr. Member
Posts: 1124
Joined: Sat Jul 27, 2013 6:10 pm

Re: Plans to go open source

Postby Isles487 » Sun May 31, 2020 8:18 pm

Hey guys!

I dusted off an old Acer Aspire Revo 1600 and installed Debian 10 to see if I could get the server running. So far so good, but I did hit a snag with INSTALLING AND SETTING UP DNAS

The PDF reads:

DNAS emulation is currently done by a few PHP scripts. The lite version of Raspbian stretch doesn’t
have it preinstalled. Let’s adjust the installation:

➢ sudo apt-get install php7.0-fpm

Last but definitely not least we’ll setup Apache to run a SSL enabled PHP7 webserver with DNAS
certificates.

However, when I run that I get the following error:

Code: Select all

Reading package lists… Done Building dependency tree Reading state information… Done E: Unable to locate package php7.0-fpm E: Couldn’t find any package by glob ‘php7.0-fpm’ E: Couldn’t find any package by regex 'php7.0-fpm’

I did check https://packages.debian.org/stretch/php7.0-fpm, I did not see my architecture listed [attached].

After running

Code: Select all

uname -m


I got

Code: Select all

i686

I was wondering if you guys could point me in the right direction. Is PHP 7.0-fpm not available for my architecture?

Would I have better luck running a Virtual Machine on my 64bit main system? I am also thinking of purchasing a Pi 4, I'm wondering if that would be the best way to go in order to have dedicated hardware for the Server.
Bit of a delayed response, but your i686 arch should be able to run i386 packages. Looks to me that the issue is that you're going to need to install php-7.3, not 7.0 - that's the version available for Debian 10.

https://packages.debian.org/bullseye/php7.3-fpm

Try installing that package and give it a whirl!

As for running a virtual machine or pi - any of those are options, though you really don't need a ton of firepower to run an outbreak server. It's a pretty light server. Most important is making sure the connection to your server machine is stable, ideally wired.
Image

User avatar
hobbes_182
Full Member
Posts: 239
Joined: Thu Jan 23, 2014 12:08 am
Location: _mobius

Re: Plans to go open source

Postby hobbes_182 » Mon Jun 01, 2020 4:29 am

Hey guys!

I dusted off an old Acer Aspire Revo 1600 and installed Debian 10 to see if I could get the server running. So far so good, but I did hit a snag with INSTALLING AND SETTING UP DNAS

The PDF reads:

DNAS emulation is currently done by a few PHP scripts. The lite version of Raspbian stretch doesn’t
have it preinstalled. Let’s adjust the installation:

➢ sudo apt-get install php7.0-fpm

Last but definitely not least we’ll setup Apache to run a SSL enabled PHP7 webserver with DNAS
certificates.

However, when I run that I get the following error:

Code: Select all

Reading package lists… Done Building dependency tree Reading state information… Done E: Unable to locate package php7.0-fpm E: Couldn’t find any package by glob ‘php7.0-fpm’ E: Couldn’t find any package by regex 'php7.0-fpm’

I did check https://packages.debian.org/stretch/php7.0-fpm, I did not see my architecture listed [attached].

After running

Code: Select all

uname -m


I got

Code: Select all

i686

I was wondering if you guys could point me in the right direction. Is PHP 7.0-fpm not available for my architecture?

Would I have better luck running a Virtual Machine on my 64bit main system? I am also thinking of purchasing a Pi 4, I'm wondering if that would be the best way to go in order to have dedicated hardware for the Server.
Bit of a delayed response, but your i686 arch should be able to run i386 packages. Looks to me that the issue is that you're going to need to install php-7.3, not 7.0 - that's the version available for Debian 10.

https://packages.debian.org/bullseye/php7.3-fpm

Try installing that package and give it a whirl!

As for running a virtual machine or pi - any of those are options, though you really don't need a ton of firepower to run an outbreak server. It's a pretty light server. Most important is making sure the connection to your server machine is stable, ideally wired.

Hey Isles487, thanks for the info I really appreciate it 8)

I was able to install php7.3-fpm. My new issue is after restarting Apache and checking the DNAS Server instead of getting the "41" in the check, I get: failed: Name or service not known. unable to resolve host address 'gate1.jp.dnas.playstation.org'

I'm sure I did something wrong on my end.

I do have a Pi4 coming in this week, I'll restart there and install php7.3-fpm there too.

Damn, so excited to get this working. Hopefully I can post some good news this week one my Pi comes in :ugeek:
Image
Image


Return to “News”



Who is online

Users browsing this forum: No registered users and 7 guests

cron